Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Compression Techniques Apple Compressor Problem – Why are AC3 files longer than the M2v files?

  • Apple Compressor Problem – Why are AC3 files longer than the M2v files?

  • Steve Martin

    October 11, 2006 at 3:23 pm

    Hi All,

    Most of the DVD programs I produce are pretty short corporate videos, so I generally simply use AIFF audio on the DVDs since I rarely have a problem with the 4.7G space limit. However, I recently worked on a project that upwards to 2 hours of material so I used Dolby 2.0 AC3 compression in Apple Compressor. In general, I accomplished what i wanted and everything is dandy.

    Except that on one the tracks on the DVD, my intention was to put several segments on a single track. That’s where I discovered a problem. It appears that when I compressed all the assets (QT reference exports from Final Cut Pro), all of my AC3 files are slightly longer (perhaps a frame or so) than the video. If that video and corresponding audio file are the only thing on that track – it’s not a problem. However, if you want to put several assets on the same track (which I’ve done without issue using PCM audio) DVDSP doesn’t like it.

    I could use seperate tracks and simply end jump from one to another – but I was hoping to eliminate the slight pause that users will have as they are watching. The other option of course is to create a seperate video asset that I can compress all as one file and simply drop chapter markers on a single track. But that’s an extra step that I was hoping to avoid.

    Obviously, there are a few work-arounds that I can employ – so file this file question under the heading, “Things that make you go Hmmmm”

    Has anyone else experienced this issue? Did I miss a setting or something in Compressor? Just the way it is – get over it and move on? Also posting this on the DVDSP forum.

    Thanks for any insight,


    Production is fun – but lets not forget: Nobody ever died on the video table!

  • Charles Simonson

    October 11, 2006 at 5:51 pm

    I see that you have two options: 1.) In DVDSP, you can shorten the length of a segment in a track. Do this to the audio segment so that it matches the video segment length. 2.) Instead of recompressing all of your assets as one file, just combine the audio source segments into one source file and then compress it. This way you don’t have to re-encode your video assets which takes exponetially longer than compressing audio.

Viewing 1 - 2 of 2 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy