Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Avid Media Composer AMA Plug-In Unable to Provide Compressed Sample

  • AMA Plug-In Unable to Provide Compressed Sample

  • Ron DeMarse

    January 26, 2018 at 11:37 pm

    I’ve searched through the forums for a similar thread and haven’t found one. If I’ve just missed it, I apologize, and please point me in the right direction.

    After a re-install of Media Composer (8.10.0), I’m having trouble linking to h264/mp4 video files (and re-linking them to existing projects). This is the case with about 95% of files of that type. I’ve come across a couple h264/mp4 files that did NOT have issues, but I can’t figure out a difference between them. And either way, I’m pretty desperate to get these files back online. They were all working before the re-install.

    When I link them via the source browser, this is the error I get on playback:

    AMAProducerTask::Execute: AMA Plug-In Unable to Provide Compressed Sample

    I ran into a similar problem linking R3D files, but that was simply a matter of re-installing the RED plugins. Maybe this could also be a plugin problem? Is it possible for the Quicktime or AVCHD plugins to become corrupted or uninstalled? If so, how can I reinstall them?

    If it might help, I can provide samples of the files that are working and not working, as well as system specs.

    Thanks, in advance, for any help you can offer!


  • Ron DeMarse

    January 26, 2018 at 11:49 pm

    I tried a little experiment and had some interesting results. With an existing project, I took one of my nonworking mp4 links, right-clicked it and attempted to “Relink to File”. It worked! It lists the QuickTime Plug-In and H.264 as the video type. When I try to create a fresh link to the SAME file, it fails with the “AMA Plug-In Unable to Provide Compressed Sample” error. Again – this is exactly the same file. But in this case, it lists the Avid Generic Plug-In and AVC Long-GOP Main as the video type. Does this mean Avid is just not recognizing it as the correct type of file? Or something else?

    I’ll attach a screenshot, in case that helps.

    Also worth noting that this re-link strategy is not working with all of the mp4/h264 files.

  • Glenn Sakatch

    January 27, 2018 at 5:06 pm

    Interesting…sounds like a bug.

    You said you re-installed 8.10. Was that the version that was installed when the original links were created?

    You did download the latest nablet plugins..not just re-install from existing files on your computer?

    If the original links were done in 8.10, but can no longer create a new link, then sounds like something has gone corrupt. If the original avid was an earlier version, it might be a bug with 8.10. Might want to roll back and see what happens.


  • Ron DeMarse

    January 28, 2018 at 8:44 pm

    Thanks, Glenn. The earlier (working) install was NOT 8.10 – it was an earlier version (but I don’t recall what). Can you point me toward “the latest nablet plugins”? I’m not sure how the plugins were installed in our latest update, but I’d love to try again with the correct versions. I really appreciate the response!


  • Andrea Cole

    January 29, 2018 at 8:36 pm

    I found the nablet plug ins and installed but its not making any difference.

Viewing 1 - 5 of 5 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can. Our Privacy policy | GDPR Policy