Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe Premiere Pro 4K Monitors and Full screen mode.

  • 4K Monitors and Full screen mode.

    Posted by Antoine Sinclaire on September 25, 2016 at 1:33 pm

    Hello, I have a 55″ 4k Samsung TV x Vertical 1080p Samsung. I do a lot of work in premiere that I’d like to see in fullscreen. But when I toggle the fullscreen button I only get a 1/4 screen image. I don’t know what’s the actual issue, whether it be the 4K monitor itself or the dual screen setup.

    Here are a few screenshots.

    Prompt help would be much appreciated.

    PS my machine.

    24 GB RAM
    Intel Core i5 2.7 Ghz
    GTX 750ti 2GB VRAM

    Yaz Al-shaater replied 4 years, 8 months ago 4 Members · 9 Replies
  • 9 Replies
  • Tero Ahlfors

    September 25, 2016 at 4:02 pm

    [Antoine SinClaire] “But when I toggle the fullscreen button I only get a 1/4 screen image.”

    Do you mean the black parts on the top and bottom of the image? What is the resolution of your footage and what is the resolution of your sequence? It looks like the footage has a wider aspect ratio than the sequence and it has letterboxing because of that.

  • Antoine Sinclaire

    September 26, 2016 at 4:34 pm

    My Timeline and Sequence are Both 1080p 24f. I’m not referring to the crop of the image itself, I ‘ve merely added a crop from the effects.
    If I’m correct PP’s fullscreen mode suppose to take up the entirety of one monitor. When I toggle fullscreen I get 1/4 the section of my TV.

  • Tero Ahlfors

    September 26, 2016 at 4:38 pm

    What GPU do you have? How is the 4K TV connected to it?

  • Antoine Sinclaire

    September 26, 2016 at 4:50 pm

    I have the GTX 750Ti and yes it’s connected to the 4K monitor.

  • Marcin Staszewski

    February 24, 2017 at 11:34 am

    Hi Antoine,
    I have a similar problem with my triple monitor setup (Full HD – 4K – Full HD monitors) as shown below:

    As you can see, when I toggle full screen preview, the video is only about 2/3 of the monitor size. I’m pretty sure that Windows item scaling may have to do something with it, as I have it set to 150%. Premiere also has a huge problem with timeline zooming using scroll wheel on 4K monitors, but thats a different problem.

    Anyway, since I couldn’t find any solution, maybe this workaround will help you:
    I noticed when I alt+tab switch to any other application during my fullscreen preview, and then go back to premiere, the image magically becomes actually full screen size. The faster method to achieve this is just pressing the start button (if you’re on windows 10 like me), which “deactivates” premiere and sets the start menu as active window, and then pressing it again to make the menu disappear, which sets premiere as an active application again. It’s a pretty quick way to get what we want, as it’s just two taps more – the fullscreen toggle key, and then windows key twice.

    Let me know if the trick works for you! 🙂

  • Antoine Sinclaire

    February 24, 2017 at 12:07 pm

    That was a trick I used to use but with my setup I was always in Fullscreen so it got tedious. Eventually I just switch to working on my 1080 monitor. Not a solution, but less tedious.

    Anytime I needed to edit 4k footage i would just use the 4k monitor but for nothing more.

    I will say it’s definitely an upscaling issue for sure having to do with the 4k, on account it would be exactly 1/4 the monitor size.

    Thanks for the feedback, Happy editing

  • Marcin Staszewski

    February 24, 2017 at 7:03 pm

    Well if all you wanted was to have the 4K monitor set as your live fullscreen preview at all times, why didn’t you just enable it as Mercury Transmit Video Device in Preferences->Playback?

  • Antoine Sinclaire

    February 24, 2017 at 7:49 pm

    My Gfx crad wasn’t all that great at running 4k footage playback, I’ve since made several upgrades…. Everything now runs smoothly…..

  • Yaz Al-shaater

    September 18, 2018 at 8:06 am

    @Marcin thanks for the workaround!

    I’ve taken time out of my super-late edit and finally registered Creative Cow (after reading it for years) because this trick has made me so happy.

    Cheers dude

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy