Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Audio Engineering ZOOM H4n Material lost on SD Card

  • ZOOM H4n Material lost on SD Card

     Oriol Nieto updated 10 months, 1 week ago 37 Members · 75 Posts
  • Sascha Engel

    December 6, 2011 at 12:36 am

    Hi Everybody,

    I really hope, somebody can help me here.
    I am really desperate about this: I just shot the show of the famous choreographer and Dancer Nigel Charnock.
    We recorded the audio from stage seperately: A ZOOM 4Hn in the stage centre and right and left to Rode NT2 Condensers. They went into the ZOOM, which recorded those two mics and with the Internal stereo mic (4 Channel modus). To give enough power for the Phantom 48V for the Rhodes, the Zoom was connected to electricity.
    Now, I think, before I could get to the Zoom after the show to stop recording, one of the stage technicians switched of the electricity of this plug and the Zoom switched off.
    Now, there is two Stereo Files created, when I open the card, but they are both 0 KB, even though in the Zoom they do not show up, but at the same time the Zoom shows less available recording time than before the show.
    My guess, it could not write all good to the disk, when the electricity got cut.

    Is there any chance it is still on the card and I could get it back somehow?

    Greetings,

    Sascha

  • Mark Barroso

    December 6, 2011 at 1:40 am

    Nope. You’re screwed. It’s an awful feeling – one that took me weeks to get over when it happened to me.

    You are correct in your diagnosis in what happened.

  • Phillip Todd

    February 4, 2012 at 7:54 pm

    Maybe clipwrap would have worked for you? My story (a little off topic, but still relevant):

    I had a case like this once on my GH2 camera while changing the battery.

    In the middle of a live event I had to swap the battery ASAP.

    I stopped recording, waited until the OSD showed card access had ended.
    I turned camera off and waited until the display went dark.
    Battery swap.
    Turned on camera and resumed shooting.

    Upon ingesting the whole card was unreadable by FCP7 L&T.
    Looking via the finder there was one file of many that reported it was zero kb.

    After 3 days of trying to find a solution with many different recovery programs, I found one that worked for me (mbp 10.5 & FCP7)

    I used Panasonic’s “AVCCAMRecovery_Mac” aka “AVCCAM SD Card File Recovery” recovery program to retrieve all the data on the card to a folder on my HD. It also uncovered files from before the card was last formatted (good to know!).
    link: https://eww.pass.panasonic.co.jp/pro-av/support/dload/avccam_recov/agree_e.htm
    More Panasonic recovery tools: https://eww.pass.panasonic.co.jp/pro-av/support/desk/e/download.htm

    The zero kb file was now a 4 GB file. The finder could even preview it! FCP could see it, try to ingest it and then would crash at the end of transcoding the file to ProRes. The rest FCP7 ingested.

    Likewise 5DtoRGB v1.5.3b would hang upon reading the last frame.

    The breakthrough:
    I used Clipwrap 2.4.6 on the recovered file (4GB) saved on my HD and it had errors.
    I used Clipwrap 2.4.6 on the file (zero kb) still on the original memory card that had been in the camera
    AND IT RECOVERED IT !!!

    Also worth checking out is Treasured. They can fix files via an online service. I didn’t need it, but, could save your bacon. https://aeroquartet.com/movierepair/repair

    In my case that “zero kb” file was actually 4 GBs worth of valuable footage. Don’t reformat your memory cards until you have recovered your zero kb files!

    Phillip Todd
    Cinematographer
    Philadelphia – NYC – Zurich

    Reel: https://vimeo.com/7355095
    Filmography: https://www.imdb.com/name/nm0865259/filmoyear

    Some contents or functionalities here are not available due to your cookie preferences!

    This happens because the functionality/content marked as “Vimeo framework” uses cookies that you choosed to keep disabled. In order to view this content or use this functionality, please enable cookies: click here to open your cookie preferences.

  • Sascha Engel

    February 4, 2012 at 9:34 pm

    Sounds amazing, thanx.
    The card is now with a friend of mine in The Netherlands – he tried to recover it.
    I will tell him to try this.
    Maybe it works.
    I will keep you updated.

    Thank you so much for sharing!

    Sascha

  • Sascha Engel

    February 4, 2012 at 9:35 pm

    I see you live in Zurich also, Todd?
    We have a show there in March, maybe you wanna come and watch.

    Sascha

  • Sascha Engel

    February 4, 2012 at 9:39 pm

    HI Todd,

    I think, the main problem is, that it’s WAV files from the ZOOM, and it’s not possible to import them to Clipwarp.

    Sascha

  • Phillip Todd

    February 7, 2012 at 8:28 pm

    Enjoy Zurich. I moved back to the USA in 2011. I’ll have to update the COW. A great artists community in Zurich. Someone has to balance out all the Bankers!

    Phillip Todd
    Cinematographer
    Philadelphia – NYC – Zurich

    Reel: https://vimeo.com/7355095
    Filmography: https://www.imdb.com/name/nm0865259/filmoyear

    Some contents or functionalities here are not available due to your cookie preferences!

    This happens because the functionality/content marked as “Vimeo framework” uses cookies that you choosed to keep disabled. In order to view this content or use this functionality, please enable cookies: click here to open your cookie preferences.

  • Phillip Todd

    February 7, 2012 at 8:38 pm

    Worth trying might be the app Treasured 2.6 from https://aeroquartet.com/movierepair/repair or maybe they can recover audio files. A human emailed me back. I think they are in Germany.

    Maybe Zoom has such a recovery program, or another audio manufacteurer for .wav files. There must be tons of programs out there as .wav files are so common in the PC world. I am sure you are not alone in having had this happen to you.

    Next time, do you need to bring an APS power supply? This really is the bleeding edge of technology. Thanks also for sharing.

    -Phillip

    Phillip Todd
    Cinematographer
    Philadelphia – NYC – Zurich

    https://vimeo.com/philliptodd

  • David Blumenfeld

    October 7, 2012 at 12:34 pm

    I picked this up off of another post after my batteries died on Zoom 4hn at the end of a 1 hour interview. IT WORKS! Even if it reads 0 on your card!

    https://zoomforum.us/viewtopic.php?f=15&t=17991

    Dear H4n Mac users,

    I thought all was lost. My batteries ran out during a shoot (phantom power drain horror) and when I got back to the studio the file came up as 0kB. But thanks to hints from forum member aumeta I’ve managed to recover it. I thought you all should know it can all be done on a mac using freeware. Follow these steps:

    1. As soon as it happens remove the SD card and don’t use it. Unknowingly, I did use it, but for less time than I had previously recorded, so I was still able to rescue a large portion of my file. The SD card works a lot more like a tape than you might imagine. So when the batteries fail, it will start recording the next file at the start of the file that failed when your batteries went. This means if you’ve recorded, say, a 25 minute track, then the batteries have run out, and then you’ve recorded 2 more 2 minute tracks on the same card with new batteries, that you can still recover the last 21 minutes of your track. Clearly, it’s better to recover all of it, so next time, carry a spare SD card, and stop using the battery damaged one!

    2. Back in the studio, plug in your SD card into the card reader so it mounts.

    3. then open
    Applications>Utilities>Terminal
    What we’re going to do is unlock some advanced features on another utility Disk Utility

    4. Once Terminal has started up copy and paste this in:
    defaults write com.apple.DiskUtility advanced-image-options 1
    then press return

    5. Now open
    Applications>Utilities>Disk Utility

    6. Select your SD card in the list of drives, then click the New Image button

    7. What we’re doing is making a copy of the entire SD card, including all the empty bits. This allows the audio program we’ll use which can read RAW files to read the entire disk image as one enormous audio file.
    So, in the Image Format tab select “Entire Device” and have encryption set to “None” and save your disk image to a drive big enough to hold it.
    instructions with pictures are here https://echoone.com/filejuicer/disk-images (ignore the last section about file juicer it will not help your problem

    8. Now you’ve got a file that you can open in your audio program. One that can do it is a piece of freeware called Audacity which I found out from the forum post by johnsantic.
    Download the Mac version from here: https://audacity.sourceforge.net/

    9. Here I’ll adapt John Santic’s instructions from this post which saved some files for me which we’re’n’t 0kB (https://www.2090.org/zoom/bbs/viewtopic.php?f=15&t=14366)
    “The normal way to load an audio file into Audacity is to use the typical “File > Open” command. But they have another way to read in a file in case the header is damaged or missing. This uses the “Project > Import Raw Data” command. The next step is to select your new disk image in the dialog box that opens.

    10. Another dialog box should open which asks for audio parameters, this should be the same as the way in which you recorded the file:
    In my case this was:

    – Signed 24-bit PCM (ie 24 bit WAV on the zoom)
    – Little-endian [this means the audio data in the file is least-significant-byte first – it will be the same whether you recorded at 24 or any other bit rate]
    – 2 Channels (Stereo)
    – Start offset = 910 [this is the normal size of an H4n header, you should also try 0 and 2 if you are at 24-bit, or 0, and 1 for 16-bit]
    – Amount to import = 100%
    – Sample rate = 48000

    After you click “Import”, Audacity reads in the file. What you’ll probably find is large blocks of interference with audio files inbetween. If you find your lost recording, select that section, then use the command “File > Export” and save it under a different file name, with the same settings as your other original sound files. Joy! OK so you’ll probably lose a tiny bit at the end and at the start, but I’m sure you’ll live having recovered the vast majority of what you thought was lost forever

    11. If you don’t find your audio file in there this time do not despair. Instead just go back to the start of part 10 and enter in a different start offset (0, 1 or 2) and you’ll find a different portion of the audio you recorded will appear. I found my lost file on the second attempt when I set it to 0. Just keep on trying.

    I thought I’d messed up the whole project. Now I’m full of the joys of life, and thought I should share it with you all.

    Ta,

    James

    Top

    zoom1061
    Post subject: Re: Ran out of Battery and found only a 0Kb file? There’s hoPosted: Wed Jul 11, 2012 4:11 pm

    new to this board

    Joined: Sun Jul 08, 2012 6:12 pm
    Posts: 1
    I just wanted to affirm Jimmybulb’s post. Thank you! and to anyone else who did the behind the scenes work to make recovery possible, you rock! I spent 4 hours troubleshooting and downloading random freeware programs, but when I found this post, all was saved except about 15 seconds that were somehow corrupted. I ran the process twice through to see if the file would come out clean but it didn’t so I’m guessing somewhere in the process of my Zoom H2 becoming unplugged, the file became corrupted. I’m not really sure. I was recording a wedding and it finished. Because my batteries were dead, I had confidently plugged my zoom H2 into a power strip thinking it was the ultimate, safe source of power. Well, the sound board just happened to be plugged into this power strip and the sound engineer unplugged it after the wedding. The zoom power was cut off before I could stop recording. Note to self – set up at least 2 layers of good quality audio backup if possible.

    A couple helpful notes.
    1. Don’t stop trying if you get an audacity file that is ALL interference. You probably got the audio parameters wrong. The sample rate, offset, stereo or mono, little endian all seems to matter. I tried multiple settings before I got the right one and sometimes the audio came out as all interference (LOUD interference) or super slow low voices.
    2. All the freeware recovery programs I tried didn’t do what I wanted. Most recover deleted files, pics, etc.. not fix audio files without a header.
    3. I tried 0 for the offset, and it came out as pure interference. 1 and 2 both worked in my case. I was recording 16bit, stereo, at 44kHz.
    4. DEFINITELY choose a low percentage to import to test first. Setting it at 5% for about 7.4GB of a card only took about 30 sec to process on my macbook pro.

    Good luck!
    Nick

  • Joe Flood

    November 7, 2012 at 6:01 pm

    Hello and thank-you for this post! I experienced a nearly identical event with my ZOOM H4… power was pulled leaving a corrupt file. I followed these instructions and all seemed encouraging. When I attempt to launch Audacity it always “unexpectedly quits”. For some reason it won’t open on my Mac (Mac Pro, OS 10.6.8).

    I tried using BIAS Peak’s “Recover Audio File” function, which seems similar to Audacity. The options are:

    Audio Data Location:
    1. In AIFF SoundDataChunk
    2. In WAVE Sound Chunk
    3. At Start of Data Fork (SD2, RAW)
    4. At Byte Position [ ]

    Byte Order:
    1. Big-Endian (AIFF, SD2)
    2. Little-Endian (WAVE)

    and Bit Depth, Sample Rate selectors.

    Using “In AIFF SoundDataChunk” or “In WAVE Sound Chunk” with “Little-Endian” produce a recovered file (2048MB) but with “Max: -90dB” level???

    Any thoughts on what could be the problem? Is there another free app like Audacity? Much appreciated!
    Thanks, Joe

Viewing 1 - 10 of 75 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy