Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X SRT Subtitles

  • SRT Subtitles

  • Greg Ball

    August 4, 2021 at 4:45 pm

    Hi Everyone,

    I had a video translated into Spanish for Subtitles. I imported the SRT file into FCPX and it works great, but when I export it, I do not see any of the subtitles!!! They play great in the project, but they are missing in the export. I would really appreciate your help. Thanks so much!

  • Eric Santiago

    August 5, 2021 at 3:59 pm

    Google it. There is an option you need to check on.

    What are you using to view?

    YouTube?

    Sorry Im no where near a Mac at the moment so I cant pinpoint the checkbox.

  • Greg Ball

    August 5, 2021 at 5:46 pm

    Thanks Eric. I was hoping someone here would be able to tell me.

    Don’t you think I Googled it first??

    Luckily Mark Spencer answered my question on Facebook.

  • Eric Santiago

    August 9, 2021 at 12:53 pm

    I suggested that cause I had to do the same thing a few years ago.

    Somedays its much quicker 🙂

  • Mark Suszko

    August 9, 2021 at 2:27 pm

    What did Spencer tell you to do to fix it?

  • Eric Santiago

    August 9, 2021 at 2:34 pm

    I use the Roles (Tab) option in Share (Export).

    Click on the Captions button (blue).

  • Michael Alberts

    August 9, 2021 at 10:06 pm

    More than likely he told him what the procedure is for exporting subtitles as Open Caption titles. It’s basically the same as closed captions with the exception of one check box.

    The first step is to Share/Master File. In the Settings choose your codec (ProRes or H.264). In the Roles tab pick your Roles. Click the blue icon that says “Captions” for the video track role. From there select the drop down next to the “Burn in captions” option and select which of your captions tracks you want burned in. It’s that simple.

    Of course these are now burned-in subs as that’s what the OP asked for. The end user now has no option to turn them on or off.

  • Greg Ball

    August 10, 2021 at 1:34 pm

    Correct. Here’s mark’s video that he sent me:

    Some contents or functionalities here are not available due to your cookie preferences!

    This happens because the functionality/content marked as “Google Youtube” uses cookies that you choosed to keep disabled. In order to view this content or use this functionality, please enable cookies: click here to open your cookie preferences.

  • Greg Ball

    August 10, 2021 at 1:38 pm

    It may be quicker, but many people have searched Google before posting a question. Telling someone to search on Google on an FCPX forum is not helpful.

  • Mark Suszko

    August 10, 2021 at 2:56 pm

    Thanks, Greg.

Viewing 1 - 10 of 12 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy