Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X Final Cut takes hours to delete an event.

  • Final Cut takes hours to delete an event.

  • Dave Smith

    December 6, 2022 at 2:58 pm

    I’ve got a few TBs of events in a library stored on a 10tb USB3 drive that are taking a dogs age to delete. Right click event, move to trash…. and in the Background Tasks pane under Media Management I’m looking at two “Move event to Trash” actions that are creeping along…. i suspect they will take 3-4 hours before the 2 delete event tasks are finished. 1% every 20 minutes or so. It’s maddening because I can only line up 2 at a time in the delete queue. With 40 events in this library it’ll be days before I can delete all the unwanted ones.

    Anyone seen this before? I’m assuming it’s because of the drive but i didn’t think deletes would grind things to a halt for hours.

    Cheers

  • Ben Balser

    December 6, 2022 at 3:12 pm

    Nope, should be instantaneous, no matter what drive you’re on. First, I’d delete all the render files for that Library, then I’d delete the preference files for FCPX. Relaunch, see what happens.

    But since you selected 40 at once, and it’s only showing two being deleted, well, maybe it’s the shear number it can’t handle. It’s not great with huge Libraries. So, as a test, how does it do deleting just one Event at a time? Try deleting 4 Events at a time, then maybe 10, just to test and see if it’s the number of Events being deleted at one time, or what.

  • Dave Smith

    December 6, 2022 at 3:23 pm

    Yea i deleted all possible render files and proxy files etc… i didn’t do the preference files tho. Will try that now. I’ve been going one event at a time, if i tried to line up a 3rd event for delete i’d get an error saying that i had to wait for current processes to finish. I’ll try to scrub the preference and see how that goes when these 2 are finished deleting in a couple hrs.

    Cheers man

  • Jeremy Garchow

    December 6, 2022 at 3:40 pm

    Is the media in the Event or outside of it? (Managed or External)

  • Eric Santiago

    December 6, 2022 at 3:56 pm

    I’ve seen this due to perm issues with mounted drives.

    Just be lucky you are not missing data.

  • Ben Balser

    December 6, 2022 at 3:58 pm

    Ah, so you are doing one at a time, and still having issues?

    Most important, be sure your system drive has minimum 20% of its capacity left as free space. Verify that right away!

    If deleting renders and preferences doesn’t work, do a reinstall. Something is seriously wrong there. I’d think media being managed/external shouldn’t matter as it’s the same physical process taking place; FCPX tells macOS to move stuff to trash and delete it, then updates its own database. I would thing updating the database would be where issues are occurring. But hey, FCPX can be pretty buggy, so who knows?

    I’ve deleted multiple Events in the past, 3 or 4 at a time, no more than maybe 30 pieces of media in each, and it was instantaneous, no issues. But if you are deleting one, and having this problem, yeah, FCPX has a bug, or something is slowing down the OS and drive, and the most common culprit would be the system drive not having enough free space, which can cause all sorts of wacko issues all over the place.

  • Dave Smith

    December 6, 2022 at 4:34 pm

    Oh god… permissions issues would be a nightmare. haha…. I wiped the fcp preferences with command-option while restarting fcp… no change: Right click one event, move to trash… hours to wait. Is that the same as manually deleting the prefs file?

    The library is 2TB in size, and the 8tb external drive its on has 4tb free… the clips for each event are in the event itself. Vanilla set up mostly.

    I have an i9 macbookpro with an 8tb SSD and 64gb ram so it should rip through most anything…. i don’t think it’s my system that’s the issue. There are 4tb free.

    Next step… reinstall fcp. Fingers crossed!

  • Ben Balser

    December 6, 2022 at 4:49 pm

    Only drive that needs enough free space is the system drive. It uses this space to write temporary working files. But yours is fine.

    A 2TB Library is freakin’ HUGE! I’d be sure to turn off background rendering, and don’t use proxies if you don’t really have to. Is this for one massive production?

    Yes, reinstall FCP, but FIRST download these!

    FCS Remover, will remove ALL FCPX app files, even the ones hidden deep inside the OS that we regular folks don’t know about. https://www.digitalrebellion.com/fcsremover/

    I’d also recommend Preference Manager, which makes deleting the pref files way easier, and you don’t have to launch FCPX with two hands. https://www.digitalrebellion.com/fcsremover/

    Finally, I highly recommend Final Cut Library Manager, it does lots of really super useful things to help maintain FCPX Libraries. https://www.arcticwhiteness.com/finalcutlibrarymanager/

    I’d also recommend running Disk First Aid on all drives just to be safe.

  • Dave Smith

    December 7, 2022 at 1:15 am

    Welp, i used fcs remover and then did a fresh reinstall. Same result.

    I’m starting to think this is normal. The clips in the Event/Library are on the USB drive. Why? Because they’re huge. When an Event is deleted in FCP, it goes to the trash. Where is the trash? On the laptop. The status of each of these deletes processes under Background Tasks > Media Management literally says, “Move Event to Trash”…….. so the event has to transfer over usb3.0 connection to the Trash. If 100gb takes ~15 mins, and i exxaggerated a bit by saying 4 hours… then a 500-600gb event would take over an hour to delete, maybe approaching 2hrs depending on how many files.

    I don’t know if that’s correct or not…. what do you think?

  • Ben Balser

    December 7, 2022 at 1:44 am

    No, files do not get physically moved. A hard drive has a directory which lists all files, and where each of those can be found on the drive. Most files are in pieces and live in various different parts of the drive. “Move To Trash” is a GUI thing, the directory simply updates to tag the data that makes up that file as being in a Trash folder (folders are not physical things, just drive directory tags to help the end user organize). Plus, each drive has its own “Trash can” so to speak. So your USB drive doesn’t copy files to your system drive’s trash, it tags it for its own trash directory. (I’m a retired IT engineer, sorry, I tend to rant) Something is seriously wrong here. I use USB thumb drives (the slowest in the world) to move files around, and they copy way faster than this. If your drive was that slow, it’d be too slow to edit on.

    Run a test. In an Event, select a file, right-click and Reveal In Finder. Now, select the folder that is that event, copy it (Cmd-C) and then paste it to your system drive (Cmd-V). Tell us how long that takes.

    AND since this is so unusual, I’ve never seen this before, I’d highly recommend posting this at FCP.co, also, as they have some folks there who are more technically knowledgable about the inner workings of FCP than most.

Viewing 1 - 10 of 14 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy