-
Intensity Pro Max File Size Problem
I have a Blackmagic Intensity Pro with the 1.8.4 software. The whole thing works in about any configuration you can throw at it. I love it (except their Media Center is way too facile and basic, but that’s not the problem).
===================================================When capturing HDMI, the problem is that Media Express ALWAYS gives capture popup Error: “Unable to capture.” at time ~1:15, file size ~535.9GB, but the timer keeps clicking away and the card’s HDMI output remains functioning until I click the “OK” button on the error box. So the biggest file I can capture in one pass is 536GB. If I start and stop Media Express before the file size gets to 536GB, I can fill my disk to the full 1.81TB with a bunch of large video files. And no, a full 536GB file does not break anything. I can restart capturing after Media Center completes writing the file, but this of course gives me a break and results in missing a few seconds of the feed.
HDMI capture is uncompressed HD 1920×1080/59.94i. I do not get dropped frames. I have reconfigured my raid drives a hundred different ways and get a data transfer rate of ~166,000kbps; Blackmagic Intensity Disk Speed Test says 42 (not 32) frames per second, which is a good margin for High Definition 4:2:2 1920×1080/59.94i. My error, “Unable to capture,” result is the same if the raid is poorly configured and drops frames.
Disk begins either totally empty, or with other files already on the disk, the error is the same. Capture disks can be 2 external Cavalry Cavalry CADA001SA2-B RAID 0 enclosures of 2x500GB set to fast Raid 0, and the 2 boxes are then striped RAID 0 = 2TB, using an on-motherboard Silicon Image 3132 raid controller with port multiplier; soft raid scsi driver. Any of my other large arrays on an Intel ICH8R controller get the same error. CPU usage is 7% nominal on an Intel E2160 dual core @ 3.0GHz; 2GB memory at 1002MHz, 5-5-5-16. Peak memory usage is 516MB. Other disks are 2x320GB Raid 0, 2x160GB Raid 0, and an 80GB system IDE disk. Pagefile is on the 2x320GB Raid 0 disk, or anywhere else.
Setup 1:
Motherboard is an Abit AB9 Pro.
Video card is an HIS ATI HD 2600 PRO 256MB HDCP with hardware HD decoding.
XP power saving is turned off, so the disks do not power down.
===================================================The results are the Same on my preferred system:
128KB Raid 0 chunk (stripe) size.
Motherboard Gigabyte GA-G33M-DS2R.
Using just the Intel ICH9R disk controller, not a Silicon Image controller.
Intel Quad Q6600 running at 3.1GHz; cpu usage 3-4% nominal.
2GB memory at 1035MHz, 5-5-5-16 (not the same ones as the other motherboard).
Video card is the same HIS ATI HD 2600 PRO 256MB HDCP.
Windows Server 2003 Enterprise R2 SP2.
===================================================
===================================================It does not seem probable that 536GB is the maximum filesize possible (although it is close to 40 binary bits, so it could be a programming error at Blackmagic).
Can anyone help? – – jerry