Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Compression Techniques ripping my hair out over compression and exporting, help?

  • ripping my hair out over compression and exporting, help?

  • Brian James

    January 6, 2009 at 9:47 pm

    Ok, I’m flipping out, I need some perspective, if anyone can offer some.

    I have sony vegas 8 on my Windows XP Pro, SP2, machine. On my macbook (running OS X 10.4.11), I have iMovie HD.

    Now, I’ve been trying to experiment with how I export video, so as to get the best looking final product. I mostly work in Vega, because iMovie is just too simple for what I need to do.

    But here’s where I am getting confused, and ripping my hair out.

    Please bear with me.

    I take a source video file, which was filmed at 720×480, not HD, just regular video, on a DV cam. I drop this into vegas, using a template that is specifically 720×480. When I export my video, though, I want it to fit the new Youtube player size (and besides, 720×480 mostly looks like crap these days) – so I export at 1280×720, using the h.264 codec. Everything exports, but, Thing is, the output file isn’t playing back at 1280×720 – but rather staying at 720×480 (or, so it seems), despite it’s file information stating that it’s 1280×720. I’m very, very confused at this point, and here’s why.

    I took that same source file (beginning at 720×480 resolution), and dropped it into iMovie, and exported at 1280×720 with the h.264 codec. Low and behold, the output video is displaying correctly at 1280×720 when played back – and when uploaded to Youtube, fills the player.

    So, what I cannot understand here is, is there something wrong with my windows system, or am I just insane? For a little reference, here are files I’ve exported, testing this out:

    Mac exported 1280×720, h.264:
    https://www.youtube.com/watch?v=G9PFflHv8BA

    Windows exported 1280×720, h.264:
    https://www.youtube.com/watch?v=Gg1uLbuwptI

    I’ve also exported one of these clips at 1280×720, using the WMV9 encoder, just to test:
    https://www.youtube.com/watch?v=Ryq9F_Wdp_I

    And again, the frame size is just wrong.

    So, I mean, what am I doing wrong? I’ve been editing on this Windows machine for years, but always exporting at 720×480, since that’s what DV shoots in, and I’ve never owned an HD camera. But now, here I am, trying to match YT’s player size and fit these new giant TV screens for a client, and ripping my hair out finding that everything I export isn’t exporting at the right size on this damn windows machine.

    I’ve scanned my installed codecs using Sherlock on my Windows machine, and everything seems ok. I’ve tried using multiple codecs, exports, everything, and nothing exports at the right frame size. Am I not selecting the right pixel ratio? I’m just… confused.

    Am I insane? Do I need to wipe out my system and reinstall? I mean, seriously, I just -cannot figure this out-, so any input would be really appreciated. Thanks.

  • Daniel Low

    January 6, 2009 at 11:11 pm

    I’m confused.

    So the 1280×720 from the Mac looks like everybody is fat, which leads me to believe that the source was 720×480 4:3 not 16:9, correct?

    Both of the other two clips the people don’t look fat (although it’s very difficult to tell) and as such the clips are at the correct aspect ratio or thereabouts.

    Do you deliberately want to distort the video for YouTube or am I missing something?

    __________________________________________________________________
    Please post back saying what solved your problem. It could help others, and saying ‘thanks’ is free!

  • Brian James

    January 6, 2009 at 11:25 pm

    Yes, the source video was 4:3, 720×480.

    My point is not that I want to match YT’s player. My point is that, no matter what I do and export from my Windows machine, it does not size the output file in the way that it should – I don’t care about the people looking fat right now – what I care about is that on the Mac with iMovie, video renders out at actual 1280×720. On the PC, it says it renders out at 1280×720, and the file’s metadata reads as so, but it’s not 1280×720.

  • Brian James

    January 6, 2009 at 11:30 pm

    also, I’d have to disagree with you – I don’t think that the people in the image look that distorted. I think that the image looks stretched, but all of that is neither here nor there for me right now. As I say, all I’m interested in figuring out is why every NLE I export video out of won’t do the size that I tell it to.

  • Daniel Low

    January 6, 2009 at 11:46 pm

    Like I said, it’s difficult to see just how fat these peoples heads look when stretched from 4:3 to 16:9. After all millions & millions of people watch 4:3 broadcasts on 16:9 TVs every day of their lives and get used to fat heads because they don;t know how to change the settings.

    Anyhow. It’s impossible to tell why Vegas is exporting your video correctly when you are explicity telling it to do it incorrectly. We’d have to walk through all the settings and application preferences to figure it out.

    Maybe it’s just one of those Clippy help animations Microsoft loves and the rest of the intelligent world hates: “Hey it looks like you’re trying to export a 4:3 video as 16:9, would you like me to correct that for you!”

    Sorry, I couldn’t resist.

    __________________________________________________________________
    Please post back saying what solved your problem. It could help others, and saying ‘thanks’ is free!

  • Brian James

    January 7, 2009 at 12:22 am

    Well, Daniel, I would say that the issue I see is that I’m telling Vegas to do something, and it’s not doing it, irregardless of correct or incorrect. It seems incorrect to me that it would export the video so that the visible moving image is 720×480, with that image inside of a 1280×720 container, but with essentially 1/3 of that container being used up by black, instead of moving image. That’s essentially what’s happening.

    The thing of it is, it’s not just Vegas 8 doing this. I’ve downloaded the vegas movie studio 9 platinum trial, and done an export at 1280×720 using AVC/h.264 as the codec, and I’m having the same experience.

    I’ve also tried an old Premiere Pro (premiere 7) trial that I found on an old Video Creator disc, and low and behold, same thing, and same output no matter what codec I use.

    I’d have to say that I’m pretty much stumped here. I mean, fact is, if I tell an encoder I want the visible image to be a certain size, it should export to that size – in the case of Windows, however, it’s not.

  • Daniel Low

    January 7, 2009 at 12:31 am

    Brian, you are right, of course. When you set a piece of software to do something the last thing you want is for it to ignore your settings and do its own thing.

    It’s one of the many reason why Windows and the applications that run on it continue to be the most irritating of tools to use.

    The REAL question though is if you have a Mac, that does exactly what you want, why on earth are you wasting away your life away bothering with trying to ‘fix’ Windows?

    __________________________________________________________________
    Please post back saying what solved your problem. It could help others, and saying ‘thanks’ is free!

  • Brian James

    January 7, 2009 at 12:49 am

    Well, the simple reason for that is cost. Vegas studio 9 platinum is $80 (which was the upgrade I thought I was going to go for), but Final Cut pro is $1500, and would require my upgrading the hell out of my mac working environment to meet its needs. I don’t like to pirate software, so what I’d like to do is make money working with Vegas right now (an opportunity which as presented itself to me over the past year or so), and then go to the higher alternative, which of course would be editing on my mac.

    All things I just don’t have the money for right now.

    It all makes me sigh, that’s for sure.

  • Daniel Low

    January 7, 2009 at 1:08 am

    You mentioned iMovie in your initial post, not FCP.. Anyway, you might really like the new version of iMovie announced yesterday…

    __________________________________________________________________
    Please post back saying what solved your problem. It could help others, and saying ‘thanks’ is free!

  • Brian James

    January 7, 2009 at 1:34 am

    Yeah, I was basically just stating in my last post that I really -want- FCP. iMovie is too simple for what I want/need to do, which is multiple tracks of video, titling, picture side by side, etc.

    I didn’t know there was a new version announced. If it adds some of the features I need, I’d be super psyched.

    If not, well, I dunno what to do. Fighting with software makes me want to die.

    In an addendum to my issues, here is what I’m seeing now – I took Vegas Platinum studio 9, opened a 1280×720 widescreen template for it, imported a piece of video at 720×480, opened the event pan/crop settings for that video in the timeline, set it to 16:9 aspect ratio, then exported the video using quicktime .mov at 1280×720 – and it’s displaying correctly *gasp*…

    Now, of course, this still seems halfway jacked to me, because I’m having to force the video to 16:9 before I even send it to the container it goes into, but, it at least shows that I -can- export this video this way – I just don’t know that I -want- to export video this way.

    Thanks for your input, either way…

Viewing 1 - 10 of 13 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy