Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Premiere Pro Problems with Adjustment Layers

  • Problems with Adjustment Layers

     Shawn Barry updated 1 month ago 5 Members · 7 Posts
  • Oscar Gotti

    November 4, 2015 at 11:05 pm

    Right, so I place an adjustment layer above my video clips, and the moment I add any kind of effect on it my preview window turns black!

    I have contacted both Adobe and Apple about this and they were clueless about any solutions.

    I have tried re-installing the OSX and Premiere which hasn’t worked either.

    The only time the adjustment layers work is when I switch the rendering mode to Software Only, but this is too slow to be a viable option. I have checked my GFX card and it is OpenCL enabled (Intel Iris Pro 1536) so I don’t see any reason why it should not work…

    Anyone experience the same issue?
    I am on Premiere Pro 2015.0.2 (I had the same problem in 2014 version too) and am on Yosemite.

  • Stephen Abbott

    November 5, 2015 at 3:04 pm

    Hi,

    Yes, I experienced this same problem in Premiere CC 2014 when moving a project from an NVidia-based Mac Pro to an AMD-based Macbook Pro. In my case, Premiere would preview (and render) black frames when I used an adjustment layer with a colour-correction effect over a clip with its own effect. Yosemite 10.10.4.

    My solution was to remove the underlying effects and stick with just the adjustment layer. Not what you want to hear, I imagine!

    What effects are you applying on the adjustment layer, and what (if any) on the layer below?


    Stephen Abbott

  • Oscar Gotti

    November 5, 2015 at 8:29 pm

    Hi Stephen and thanks for the reply,

    So if I understand you correctly, you would have an effect on clip, as well as the adjustment layer? And the adjustment layer effect would only work for you when you deleted an effect on the clip itself?

    I am currently upgrading to El Capitan, hopefully that will solve the issue.

    Thanks

  • Stephen Abbott

    November 6, 2015 at 6:24 am

    Hi Oscar,

    Yes, that’s correct. For me: adjustment layer effect + clip effect = black frame. Switching off either fixed the problem.

    What effects do you have on the adjustment layer, and on the clip (if any)? I was using the adjustment layer for a fast-n-nasty vignette in CC2014, 2015 removed the need for this with the excellent Lumetri colour effect.


    Stephen Abbott

  • Tero Ahlfors

    November 6, 2015 at 9:57 am

    [Oscar Gotti] “Intel Iris Pro 1536”

    That GPU isn’t officially supported. You can force it to run the GPU accelerated effects but they might not work properly as you can see.

  • Tadeu Machado

    June 20, 2016 at 4:50 pm

    Hello guys.
    Finally some feedback on this matter.
    Still no solution yet?
    Thanks

  • Shawn Barry

    April 9, 2021 at 4:18 pm

    In case anyone stumbles on this thread…

    Tadeu and OP – I realize it’s been about 5 years since this post and everyone here has obviously well moved on from this, but since this wasn’t answered, I’ll add this note. I had the same issue and other solutions that worked for others didn’t work for me. But, when I opened another one of my projects using footage from the exact same camera and settings, it was fine. That’s what got me thinking about the project itself, not the settings, was toast. I tested it and started a new project and it worked fine. I re-opened the problem project and deleted the adjustments layers from the project completely, created new Adjustment layers, applied Lumetri and it worked fine. Hope that helps some with this issue who find this.

Viewing 1 - 7 of 7 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy